题目:点击打开题目链接
Problem Description:
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
Input:
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
Output:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
Sample Input:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output:
light the wand
accio
what?
what?
思路:这道题暴力稳过,有很多大佬是用map过的,菜鸟的我还驾驭不了map的使用,就用的暴力写的。主要要注意字符串的输入处理,注意空格和换行。(注释的是另一种方法)
MY DaiMa:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
struct String
{
char s1[25],s2[85];
}s[100005];
int main()
{
char ch[105];
int index = 0;
while(gets(ch))///gets可以接收空格,遇到换行就结束
//while(~scanf("%s",s[index].s1))
{
//if(s[index].s1[0] == '@') break;
//getchar();///这里用来吃中间那个空格
//gets(s[index].s2);///输入后面的字符串
int i = 0,j = 0,k;
int len = strlen(ch);
for(k = 0; k < len; k++)///把魔咒字符串传入s1中
{
s[index].s1[i++] = ch[k];
if(ch[k] == ']')
break;
}
for(k = k+2; k < len; k++)///把功能字符串传入s2中
s[index].s2[j++] = ch[k];
if(ch[0] == '@') break;
index++;
}
int n;
cin >> n;
getchar();
while(n--)
{
gets(ch);
int num = -1;
if(ch[0] == '[')///如果是魔咒的话,输出其功能
{
for(int i = 0; i < index; i++)
{
if(strcmp(ch,s[i].s1) == 0)
{
num = i;
break;
}
}
if(num != -1)
cout << s[num].s2 << endl;
}
else///如果是功能的话,输出其魔咒
{
for(int i = 0; i < index; i++)
{
if(strcmp(ch,s[i].s2) == 0)
{
num = i;
break;
}
}
if(num != -1)
{
for(int i = 1; i < strlen(s[num].s1)-1; i++)///注意括号不用输出
cout << s[num].s1[i];
cout << endl;
}
}
if(num == -1)///找不到的话输出what?
cout << "what?" << endl;
}
}