大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3 4 1 3 0 0 0
Sample Output
NO 3
C++版本一
BFS+剪枝
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
int m0,n0,s0,ans;
int vis[110][110][100];
struct node{
int s,n,m,cnt;
}front1,start,temp;
queue <node>Q;
bool p(node t){
if(t.s==0&&t.m==t.n)
return true;
if(t.m==0&&t.s==t.n)
return true;
if(t.n==0&&t.m==t.s)
return true;
return false;
}
void bfs(){
while(!Q.empty())
Q.pop();
if(start.s%2==1) return;
Q.push(start);
while(!Q.empty()){
front1=Q.front();
Q.pop();
//cout<<front1.s<<" "<<front1.m<<" "<<front1.n<<endl;
if(p(front1)) {
ans=front1.cnt;
return;
}
//从s中向m,n倒
if(front1.s>0){
//s to m
if(front1.m<m0){
temp.cnt=front1.cnt+1;
temp.n=front1.n;
if(front1.s+front1.m-m0<0){
temp.s=0;
temp.m=front1.s+front1.m;
}
else{
temp.s=front1.s+front1.m-m0;
temp.m=m0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
//s to n
if(front1.n<n0){
temp.cnt=front1.cnt+1;
temp.m=front1.m;
if(front1.s+front1.n-n0<0){
temp.s=0;
temp.n=front1.s+front1.n;
}
else{
temp.s=front1.s+front1.n-n0;
temp.n=n0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
}
//从m中向s,n倒
if(front1.m>0){
//m to s
if(front1.s<s0){
temp.cnt=front1.cnt+1;
temp.n=front1.n;
if(front1.s+front1.m-s0<0){
temp.m=0;
temp.s=front1.s+front1.m;
}
else{
temp.m=front1.s+front1.m-s0;
temp.s=s0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
//m to n
if(front1.n<n0){
temp.cnt=front1.cnt+1;
temp.s=front1.s;
if(front1.n+front1.m-n0<0){
temp.m=0;
temp.n=front1.n+front1.m;
}
else{
temp.m=front1.m+front1.n-n0;
temp.n=n0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
}
//从n中向s,m倒
if(front1.n>0){
//n to s
if(front1.s<s0){
temp.cnt=front1.cnt+1;
temp.m=front1.m;
if(front1.s+front1.n-s0<0){
temp.n=0;
temp.s=front1.s+front1.n;
}
else{
temp.n=front1.s+front1.n-s0;
temp.s=s0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
//n to m
if(front1.m<m0){
temp.cnt=front1.cnt+1;
temp.s=front1.s;
if(front1.n+front1.m-m0<0){
temp.n=0;
temp.m=front1.n+front1.m;
}
else{
temp.n=front1.m+front1.n-m0;
temp.m=m0;
}
if(vis[temp.s][temp.m][temp.n]==0){
vis[temp.s][temp.m][temp.n]=1;
Q.push(temp);
}
}
}
}
}
int main()
{
while(cin>>s0>>m0>>n0){
memset(vis,0,sizeof(vis));
if(s0==0&&m0==0&&n0==0) break;
ans=0;
start.s=s0;
start.m=0;
start.n=0;
start.cnt=0;
vis[s0][m0][n0]=1;
bfs();
if (ans==0) cout << "NO" << endl;
else cout << ans << endl;
}
//cout << "Hello world!" << endl;
return 0;
}
C++版本二
BFS
分析:
这题代码有150行 但是基本是六中情况的重复了
先说题目 给三个数字 s n m s=n+m s在1到100之间
就是个倒水问题可以从第一个倒向第二个 类似的一共可以有六中到发
现在要求最少经过多少步就能平分那么多水
首先剪枝是 如果s是奇数必然不行。
一看到要求最少的步数就知道用bfs了
我们用vis标记状态
每个状态有三个整数组成 表示这三个杯子里的可乐数量
然后对每个状态的递推是 6种 也就是3!种。从一个到到另一个 再标记 入队
所以 题目还是蛮简单的
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int v[5];
int sign[110][110][100];
struct cup//记录遍历中3个水杯容藏可乐情况
{
int v[5];
int step;
}temp;
void pour(int a,int b)//倒水函数,把a杯子中的可乐倒到b杯子中
{
int sum=temp.v[a]+temp.v[b];
if(sum>=v[b])
temp.v[b]=v[b];
else
temp.v[b]=sum;
temp.v[a]=sum-temp.v[b];
}
void bfs()
{
int i,j;
queue<cup>q;
cup cnt;
cnt.v[1]=v[1];
cnt.v[2]=0;
cnt.v[3]=0;
cnt.step=0;
q.push(cnt);
memset(sign,0,sizeof(sign));
sign[v[1]][0][0]=1;
while(!q.empty())
{
cnt=q.front();
q.pop();
if(cnt.v[1]==cnt.v[3]&&cnt.v[2]==0)
{
printf("%d\n",cnt.step);
return ;
}
for(i=1;i<4;++i)
{
for(j=1;j<4;++j)
{
if(i!=j)//自己不倒水给自己
{
temp=cnt;//每个水位情况都要把所有操作枚举一遍,所以都要赋值为原始水位情况
pour(i,j);
if(!sign[temp.v[1]][temp.v[2]][temp.v[3]])
{
temp.step++;
q.push(temp);
sign[temp.v[1]][temp.v[2]][temp.v[3]]=1;
}
}
}
}
}
printf("NO\n");
}
int main()
{
while(scanf("%d%d%d",&v[1],&v[2],&v[3])&&v[1]||v[2]||v[3])
{
if(v[2]>v[3])
{
int t=v[2];
v[2]=v[3];
v[3]=t;
}
bfs();
}
return 0;
}
C++版本三
数论
分析:设两个小瓶子容积分别为a,b,问题转化成通过两个小瓶子的若干次倒进或倒出操作得到(a+b)/2体积的可乐,设两个小瓶子被倒进或倒出x次和y次(这里的x和y是累加后的操作,即x=第一个瓶子倒出的次数-倒进的次数,y=第二个瓶子倒出的次数-倒进的次数),那么问题转化成:
所以|x+|y|的最小值为(c+d)/2,通过x和y的通解形式显然可以看出x和y一正一负,不妨设x<0,那么就是往第一个小瓶子倒进x次,第二个小瓶子倒出y次,但是由于瓶子容积有限,所以倒进倒出操作都是通过大瓶子来解决的,一次倒进操作后为了继续使用小瓶子还要将小瓶子中可乐倒回大瓶子中,倒出操作同理,所以总操作次数是(c+d)/2*2=c+d,但是注意最后剩下的(a+b)/2体积的可乐一定是放在两个小瓶子中较大的那个中,而不是再倒回到大瓶子中,所以操作数要减一,答案就是c+d-1
#include <bits/stdc++.h>
using namespace std;
int gcd(int a,int b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int a,b,c;
while(cin>>a>>b>>c&&(a&&b&&c))
{
a/=gcd(b,c);
if(a&1)
cout<<"NO"<<endl;
else
cout<<a-1<<endl;
}
return 0;
}
C++版本四
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<math.h>
using namespace std;
int vis[105][105];
int s,n,m;
struct point{
int all,x,y,k;
};
void bfs(point a){
queue<point>q;
vis[a.x][a.y]=1;
q.push(a);
while(!q.empty()){
point next,p;
p=q.front(); q.pop();
if(p.all==p.y&&p.all==s/2){
printf("%d\n",p.k);
return ;
}
if(p.all+p.x>m){//s倒m
next.all=p.all+p.x-m;
next.x=m;
next.y=p.y;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
else {
next.all=0;
next.x=p.all+p.x;
next.y=p.y;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
if(p.all+p.y>n){//s倒n
next.all=p.all+p.y-n;
next.x=p.x;
next.y=n;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
else {
next.all=0;
next.x=p.x;
next.y=p.all+p.y;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
if(p.x+p.y>n){//m倒n
next.all=p.all;
next.x=p.x+p.y-n;
next.y=n;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
else {
next.all=p.all;
next.x=0;
next.y=p.x+p.y;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
//m倒s
next.all=p.all+p.x;
next.x=0;
next.y=p.y;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
if(p.x+p.y>m){//n倒m
next.all=p.all;
next.x=m;
next.y=p.x+p.y-m;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
else {
next.all=p.all;
next.x=p.x+p.y;
next.y=0;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
//n倒s
next.all=p.all+p.y;
next.x=p.x;
next.y=0;
next.k=p.k+1;
if(!vis[next.x][next.y]){
q.push(next);
vis[next.x][next.y]=1;
}
}
printf("NO\n");
}
int main(){
while(scanf("%d%d%d",&s,&n,&m)&&n){
if(s%2){
printf("NO\n");
continue;
}
memset(vis,0,sizeof(vis));
if(m>n) swap(m,n); //m小
point p;
p.all=s,p.x=0,p.y=0,p.k=0;
bfs(p);
}
return 0;
}