Description
兔子繁殖问题。设有一对新生的兔子,从第三个月开始他们每个月月初都生一对兔子,新生的兔子从第三个月月初开始又每个月生一对兔子。按此规律,并假定兔子没有死亡,n(n<=20)个月月末共有多少个兔子?
Input
多组测试数据,每组输入整数n
Output
每组输出一行,值为n个月后的兔子对数
Sample Input
3
Sample Output
2
分析
月份—>兔子数量
1----->1
2----->1
3----->2
4----->3
5----->5
6----->8

   #include <stdio.h>
    #include <stdlib.h>
    
    /* run this program using the console pauser or add your own getch, system("pause") or input loop */
    int t(int n){
    	
    	int k;
    	
    	if(n==1||n==2) k=1;
    	if(n>2) k=t(n-1)+t(n-2);
    	return k;
    }
    int main(int argc, char *argv[]) {
    	
    	int n; 
    	while(scanf("%d",&n)!=EOF){
    		
    		printf("%d\n",t(n));
    		
    	} 
    	return 0;
    }