Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
AC代码如下:
#include<stdio.h>
#include<string.h>
using namespace std;
bool vis[27][27];
int ansx[30];//ansx为什么开27就不对呢,奇怪。
int ansy[30];
int map[27][27];
int p,q;
bool ok=0;
int top;
int way[8][2]={
{
-1,-2},{
1,-2},{
-2,-1},{
2,-1},{
-2,1},{
2,1},{
-1,2},{
1,2}};
void dfs(int x,int y)
{
if(ok) return ;
if(top==p*q)
{
ok=1;
printf("top=%d",top);
for(int i=0;i<top;i++)
{
printf("%c%d",ansy[i]+'A'-1,ansx[i]);
}
return ;
}
int tx,ty;
for(int k=0;k<=7;k++)
{
tx=x+way[k][0];
ty=y+way[k][1];
if(!vis[tx][ty]&&tx>=1&&ty>=1&&tx<=p&&ty<=q)
{
vis[tx][ty]=1;
ansx[top]=tx;
ansy[top++]=ty;
dfs(tx,ty);
vis[tx][ty]=0;
top--; //top别忘记减1
}
}
}
int main()
{
int t; int m=0;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&p,&q);
ok=0;//别忘记将OK值刷新
memset(vis,0,sizeof(vis));
top=0;
ansx[top]=1; ansy[top++]=1;
vis[1][1]=1;
printf("Scenario #%d:\n",++m);
dfs(1,1);
if(ok) printf("\n");
if(!ok) printf("impossible\n");
printf("\n");
}
}