Description
还记得以前小学时的九九乘法口诀吧。现在要求你编写程序打印出乘法口诀。 不过现在的乘法口诀表跟以前稍微有点区别,我告诉你一个数字n( 1 <= n <= 9),你要给我打出相应的nn乘法口诀表。

Input
多个测试数据。每个测试数据一行,输入整数n.

Output
输出nn乘法口诀表。 每个乘法口诀表中的任何一个乘式占6列,不足6列的在后面补空格。同一行2个乘式之间有一个空格。 两个乘法口诀表之间有一个空行。注意乘法口诀中每一行最后没有空格,如44=16和55=25后面都没有空格的。

Sample Input
1
2
6

Sample Output
11=1
1
1=1
12=2 22=4
11=1
1
2=2 22=4
1
3=3 23=6 33=9
14=4 24=8 34=12 44=16
15=5 25=10 35=15 45=20 55=25
1
6=6 26=12 36=18 46=24 56=30 6*6=36

C++版本一

    #include <stdio.h>
    #include <stdlib.h>
    
    int main(int argc, char *argv[]) {
    	
    	int n;//输入数 
    	int i,j;//循环变量 
    	//多组数据输入 
    	while (scanf("%d",&n)!=EOF&&n>=0&&n<=9){
    	//循环输出 
    	for(i=1;i<=n;i++){
    	
    		for(j=1;j<=i;j++){
    			
    		if(i==j)
    			printf("%d*%d=%-2d",j,i,i*j);//%-2d左对齐格式 
    		else
    			printf("%d*%d=%-2d ",j,i,i*j);
    						
    		}		
    		
    		printf("\n");
    				
    	}
    	
    		printf("\n");
    		
    	} 
    	
    	return 0;
    }

JAVA版本一

public class TimesTable {
	public static void main(String[] args) {
		//System.out.println("Hello world!");
		for(int i=1;i<=9;i++) {
			for(int j=1;j<=i;j++) {
				System.out.print(j+"*"+i+"="+i*j+"\t");
			}
			System.out.println();
		}
	}
}