Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions. 

Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4
#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
const	int N=1010;
int d[N];
int g[N][N];
bool st[N];
int n,m;
int dijkstra()
{
   
		for(int i=1;i<=n;i++)
		d[i]=g[1][i];//初始化也不一样,距离d数组如果赋初值为0x3f3f3f3f就会错误。把1到所有点单条边的值给d,同时单挑边不存在不如赋值为-1好在后面更新。
		d[1]=0;
	for(int i=0;i<n;i++)
	{
   
		int t=-1;
		for(int j=1;j<=n;j++)
		if(!st[j]&&(t==-1||d[t]<d[j]))
		t=j;
		st[t]=1;
		for(int j=1;j<=n;j++)
		d[j]=max(d[j],min(d[t],g[t][j]));//这里和最短路有所不同了,里层的min是为了确定最短的边外层是为了找出所有情况里最长的边。
	}

	return d[n];
}
int main()
{
   
	int t;
	int k=0;
	scanf("%d",&t);
	while(t--)
	{
   
		memset(st,0,sizeof st);
		memset(g,-0x3f,sizeof g);
		scanf("%d%d",&n,&m);
		while(m--)
		{
   
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		g[a][b]=g[b][a]=max(g[a][b],c);
		}
		printf("Scenario #%d:\n",++k);
		int t=dijkstra();
		printf("%d\n\n",t);
	}
	return 0;
}