Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 

C++版本一 

#include<cstdio>
#include<iostream>
#include<cmath>
#include <string.h>
using namespace std;
int n,m,sum,ans;
bool dp[1000][1000];
int l[50];
int area(int x,int y,int z)
{
    double p=(x+y+z)/2.0;
    return int(sqrt(p*(p-x)*(p-y)*(p-z))*100);
}
int main()
{

    while(scanf("%d",&n)!=-1)
    {   sum=0;
        for(int i=0;i<n;++i){
            scanf("%d",&l[i]);
            sum+=l[i];
        }
        //一半
        m=sum/2-((sum&1)==0);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int k=0;k<n;++k)
            for(int i=m;i>=0;--i)
                for(int j=i;j>=0;--j)
                    if(dp[i][j])
                        dp[i+l[k]][j]=dp[i][j+l[k]]=1;
        ans=-1;
        for(int i=1;i<=m;++i)
            for(int j=1;j<=i;++j)
                if(dp[i][j])ans=max(ans,area(i,j,sum-i-j));
        printf("%d\n",ans);
    }
    return 0;
}

 C++版本二

#include <bits/stdc++.h>
using namespace std;
const int N=1605;///40*40
int dp[N][N]={0};///dp[i][j]代表能否构成i,j两边
int a[50];
int area(int a,int b,int c)
{
    double p=(a+b+c)/2.0;
    return (int)100*sqrt(p*(p-a)*(p-b)*(p-c));
}
int main()
{
    int n,sum=0;
    cin>>n;
    for(int i=0;i<n;i++)
        cin>>a[i],sum+=a[i];
    dp[0][0]=1;
    for(int i=0;i<n;i++)
        for(int j=sum;j>=0;j--)
            for(int k=j;k>=0;k--)
                if(j>=a[i]&&dp[j-a[i]][k]||k>=a[i]&&dp[j][k-a[i]])
                    dp[j][k]=1;
    int maxs=-1;
    for(int i=sum;i>0;i--)
        for(int j=i;j>0;j--)
        {
            if(dp[i][j])
            {
                int k=sum-i-j;
                if(i<j+k||i+j>k)///判断三边是否组成三角形
                    maxs=max(maxs,area(i,j,k));
            }
        }
    if(maxs==-1) cout<<"-1"<<'\n';
    else cout<<maxs<<'\n';
    return 0;
}