Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows. 

 

Figure 1



Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC 
FJK 
IHE 

then the water pipes are distributed like 

 

Figure 2



Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show. 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50. 

Output

For each test case, output in one line the least number of wellsprings needed. 

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3

C++版本一

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int N=60;
int n,m,pre[N*N];
char str[N][N];
int pipe[11][4]={{1,1,0,0},
{1,0,0,1},
{0,1,1,0},
{0,0,1,1},

{1,0,1,0},
{0,1,0,1},
{1,1,0,1},
{1,1,1,0},

{0,1,1,1},
{1,0,1,1},
{1,1,1,1},};
struct node{
    int n,w,s,e;
    node(){};
    node(int*p){
        n=*p;
        w=*(p+1);
        s=*(p+2);
        e=*(p+3);
    }
}farm[N][N];
//struct edge{
//    int f,t;
//    edge(){};
//    edge(int a,int b){
//        f=a;
//        t=b;
//    }
//}e[N*N*4];
int find(int x){
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    return r;

}
void join(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        pre[fx]=fy;

}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF&&n>0&&m>0){
        for(int i=0;i<m;i++){
            scanf("%s",str[i]);
            for(int j=0;j<n;j++){
                farm[i][j]=node(pipe[str[i][j]-65]);
            }
        }

        for(int i=1;i<=m*n;i++)
            pre[i]=i;

        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                if(i+1<m&&farm[i][j].s==1&&farm[i+1][j].n==1){
                    //e[++cnt]=node(n*i+j+1,n*(i+1)+j+1);
                    join(n*i+j+1,n*(i+1)+j+1);
                }
                if(j+1<n&&farm[i][j].e==1&&farm[i][j+1].w==1){
                    //e[++cnt]=node(n*i+j+1,n*i+(j+1)+1);
                    join(n*i+j+1,n*i+(j+1)+1);
                }
            }
        }
        int cnt=0;
        for(int i=1;i<=m*n;i++)
            if(pre[i]==i)
                cnt++;

        cout << cnt << endl;

    }
    //cout << "Hello world!" << endl;
    return 0;
}

C++版本二

看这这几张图有点懵,其实只要仔细看,也没有很难。因为他的连通就是一个十字形。分成I和一考虑

与上面有联系的是 ABEGHJK(及下面出头)

与下面有联系的是CDEHIJK

#include<stdio.h>
const int MAXN=110;
char map[MAXN][MAXN];
int F[MAXN*MAXN];

int find(int x)
{
    if(F[x]==-1) return x;
    return F[x]=find(F[x]);
}    
void bing(int a,int b)
{
    int t1=find(a);
    int t2=find(b);
    if(t1!=t2) F[t1]=t2;
}    
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n))
    {
        if(m<0||n<0) break;
        for(int i=0;i<m;i++)
          scanf("%s",&map[i]);
        for(int i=0;i<m*n;i++)
          F[i]=-1;
        for(int i=0;i<m;i++)
          for(int j=0;j<n;j++)
          {
              if(i>0&&(map[i][j]=='A'||map[i][j]=='B'||map[i][j]=='E'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='J'||map[i][j]=='K'))
                if(map[i-1][j]=='C'||map[i-1][j]=='D'||map[i-1][j]=='E'||map[i-1][j]=='H'||map[i-1][j]=='I'||map[i-1][j]=='J'||map[i-1][j]=='K')
                   bing(i*n+j,(i-1)*n+j);
              
              
                   
              if(j>0&&(map[i][j]=='A'||map[i][j]=='C'||map[i][j]=='F'||map[i][j]=='G'||map[i][j]=='H'||map[i][j]=='I'||map[i][j]=='K'))
                if(map[i][j-1]=='B'||map[i][j-1]=='D'||map[i][j-1]=='F'||map[i][j-1]=='G'||map[i][j-1]=='I'||map[i][j-1]=='J'||map[i][j-1]=='K')
                   bing(i*n+j,i*n+j-1);
          }    
       int res=0;
       for(int i=0;i<m*n;i++)
         if(F[i]==-1) res++;
       printf("%d\n",res);
    }    
    return 0;
}

C++版本三

DFS

解题思路:明显的DFS求连通区域,不过难点在于对农田水管的处理,我们可以开一个结构体数组,里面存放每一块农田四方向的水管,1代表有,0代表无。在搜索的过程中,假如当前的农田有向上的水管,而当前
农田的上面一块农田恰好有向下的水管,那么就可以从当前的水管向上搜索了。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m;
int maps[60][60];
int vis[60][60];
struct node
{
    int up;
    int down;
    int left;
    int right;
};
node num[11]= {{1,0,1,0},{1,0,0,1},{0,1,1,0},{0,1,0,1},{1,1,0,0},{0,0,1,1},
    {1,0,1,1},{1,1,1,0},{0,1,1,1},{1,1,0,1},{1,1,1,1}};
void DFS(int x,int y)
{
    int i;
    int a,b;
    if(x<=0||x>m||y<=0||y>n||vis[x][y])
    {
        return ;
    }
    vis[x][y]=1;
    for(i=0; i<4; i++)
    {
        if(i==0)///向上走
        {
            a=x-1;
            b=y+0;
            if(num[maps[x][y]].up&&num[maps[a][b]].down)
            {
                DFS(a,b);
            }
        }
        else if(i==1)///向下走
        {
            a=x+1;
            b=y+0;
            if(num[maps[x][y]].down&&num[maps[a][b]].up)
            {
                DFS(a,b);
            }
        }
        else if(i==2)///向左走
        {
            a=x+0;
            b=y-1;
            if(num[maps[x][y]].left&&num[maps[a][b]].right)
            {
                DFS(a,b);
            }
        }
        else if(i==3)///向右走
        {
            a=x+0;
            b=y+1;
            if(num[maps[x][y]].right&&num[maps[a][b]].left)
            {
                DFS(a,b);
            }
        }
    }
    return ;
}
int main()
{
    char ch;
    int i,j;
    int counts;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        if(m==-1&&n==-1)
        {
            break;
        }
        getchar();
        counts=0;
        for(i=1; i<=m; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%c",&ch);
                maps[i][j]=ch-'A';
            }
            getchar();
        }

        for(i=1; i<=m; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(!vis[i][j])
                {
                    counts++;
                    DFS(i,j);
                }
            }
        }
        printf("%d\n",counts);
    }
    return 0;
}