http://acm.hdu.edu.cn/showproblem.php?pid=2639

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link: 

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602 

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum. 

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. 

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31). 

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
0
/*
*@Author:   STZG
*@Language: C++
*/
#include <bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<cstdio>
#include<string>
#include<vector>
#include<bitset>
#include<queue>
#include<deque>
#include<stack>
#include<cmath>
#include<list>
#include<map>
#include<set>
//#define DEBUG

using namespace std;
typedef long long ll;
const int N=10000;
const double PI = acos(-1.0);
const double EXP = 1E-8;
const int INF = 0x3f3f3f3f;
int t,n,m,k,v;
int a[200],b[200],dp[N][50],A[50],B[50];
void init(){
    memset(dp,0,sizeof(dp));
    memset(A,0,sizeof(A));
    memset(B,0,sizeof(B));
}
int main()
{
#ifdef DEBUG
	freopen("input.in", "r", stdin);
	//freopen("output.out", "w", stdout);
#endif
     scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&v,&k);
        init();
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        for(int i=1;i<=n;i++){
            for(int j=v;j>=b[i];j--){
                for(int p=1;p<=k;p++){
                    A[p]=dp[j-b[i]][p]+a[i];
                    B[p]=dp[j][p];
                }
                int x=1,y=1,z=1;
                A[k+1]=B[k+1]=-1;
                while(z<=k&&(A[x]!=-1||B[y]!=-1)){
                    if(A[x]>B[y]){
                        dp[j][z]=A[x++];
                    }else{
                        dp[j][z]=B[y++];
                    }
                    if(dp[j][z]!=dp[j][z-1])
                        ++z;
                }
            }
        }
        printf("%d\n",dp[v][k]);
    }
    //cout << "Hello world!" << endl;
    return 0;
}