Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

C++版本一

#include <iostream>
#include <stdio.h>
#include <string>
#include <algorithm>

using namespace std;
int n,c;
long long line[100010];
bool sloved(long long mid){
    //for(int k=2;k<=n-c+1;k++){
        long long cnt=1,sum=0;
        for(int i=2;i<=n;i++){
            sum+=line[i]-line[i-1];
            if(sum>=mid){
                sum=0;
                cnt++;
            }
        }
        if(cnt>=c) return 1;
    //}
    return 0;
}
int main()
{
    scanf("%d%d",&n,&c);
    line[0]=0;
    for(int i=1;i<=n;i++)
        scanf("%I64d",&line[i]);
    sort(line+1,line+n+1);
    long long l=1;
    long long r=line[n]-line[1];
    long long mid,ans=0;
    while(l<=r){
        mid=(l+r)/2;
        if(sloved(mid)){
            ans=mid;
            l=mid+1;
        }else{
            r=mid-1;
        }
    }
    cout << ans << endl;
    //cout << "Hello world!" << endl;
    return 0;
}

C++版本二

二分查找可行解 
记住二分的模板,就以这题的二分为标准

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int s[maxn];
int n,m;
bool ok(int x)
{
    int cnt = 1;
    int tmp = s[0];
    for(int i = 1 ; i < n ; i ++) {
        if(s[i]-tmp >= x) {
            cnt ++;
            tmp = s[i];
        }
    }
    return cnt >= m;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i = 0 ; i < n ; i ++) scanf("%d",&s[i]);
    sort(s,s+n);
    int ma = s[n-1]-s[0],mi = 0;
    while(ma > mi) {
        int mid = mi + (ma-mi+1)/2;
        if(ok(mid)) mi = mid;
        else ma = mid-1;
    }
    printf("%d\n",mi);
    return 0;
}