N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。 
当N = 0,输入结束。

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output

1 1 1
3 2 1

C++版本一

时间复杂度为什么是log(n)?

首先树状数组的思想本身就是一个树,所以在操作的时间复杂度上面和树相似

还可以通过计算来论证:

假设现在的节点是n,那么到达父节点的方法就是:

n=n+n&-n   (不知道为什么这样写的,自行百度)

实际上就是把n的二进制最左边的1向左移动了一位,比如2-10,4-100

到达子节点的方法就是:

n=n-n&-n 

这个实际上就是每次把最左边的1变成0,比如7-111,6-110,4-100

那么这样二进制的位移运算的时间复杂度是log(n),所以树状数组查询和统计的时间复杂度也为log(n)

解题思路

这道题可以用很多方法来做,线段树是最容易想到的,但是代码实现上很复杂

其实这道题可以把每次染色的点抽象为每次涂改的区间,然后对要查询的点所在区间的更新次数进行求和

这样就可以在时间上,大大缩短,查询和统计的时间复杂度都为log(n)

树状数组中的每个节点都代表了一段线段区间,每次更新的时候,根据树状数组的特性可以把b以前包含的所有区间都找出来,然后把b以前的区间全部加一次染色次数。然后,再把a以前的区间全部减一次染色次数,这样就修改了树状数组中的[a,b]的区间染色次数,查询每一个点总的染色次数的时候,就可以直接向上统计每个父节点的值,就是包含这个点的所有区间被染色次数,这就是树状数组中向下查询,向上统计的典型应用

Ps:根据个人理解层次的不同,这道题也可以向上查询,向下统计,还可以向下查询,向下统计,不过我写的这种是最容易理解的

代码实现如下:

用cin,cout进行读写操作的话,会超时,所以我还是用的scanf(),printf()

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n,tree[100100];
int lowbit(int x){
    return x&(-x);
}
void updata(int i,int C){
    if(!i)return;
    while(i>0){
        tree[i]+=C;
        i-=lowbit(i);
    }
}
int query(int i){
    int res=0;
    while(i<=n){
        res+=tree[i];
        i+=lowbit(i);
    }
    return res;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        int t=n;
        int a,b;
        memset(tree,0,sizeof(tree));
        while(t--){
            scanf("%d%d",&a,&b);

                updata(b,1);
                updata(a-1,-1);

        }
        for(int i=1;i<=n;i++){
            if(i<n)
                printf("%d ",query(i));
            else
                printf("%d\n",query(i));
        }
    }
    //cout << "Hello world!" << endl;
    return 0;
}

C++版本二

线段树

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define max_n 1000010
using  namespace std;
typedef long long LL;

struct node{
    int l;
    int r;
    int sum;
}s[max_n];

void pushup(int root){
    s[root].sum=s[root<<1].sum+s[root<<1|1].sum;
}

void build(int root,int L,int R){
    s[root].l=L;
    s[root].r=R;
    if(L==R){
        s[root].sum=0; 
        return;
    }
    int mid=(L+R)>>1;
    build(root<<1,L,mid);
    build(root<<1|1,mid+1,R);
    pushup(root);
}

void updata(int root,int x,int y){
    if(s[root].l==s[root].r){
        s[root].sum+=y;
        return;
    }
    int mid=(s[root].l+s[root].r)>>1;
    if(mid>=x)
        updata(root<<1,x,y);
    else updata(root<<1|1,x,y);
    pushup(root); 
}

int query(int root,int L,int R){
    if(s[root].l==L && s[root].r==R){
        return s[root].sum;
    }
    int mid=(s[root].l+s[root].r)>>1;
    if(mid>=R)
        return query(root<<1,L,R);
    else if(mid<L)
        return query(root<<1|1,L,R);
    else
        return (query(root<<1,L,mid)+query(root<<1|1,mid+1,R));
}

int main(){
    int n,l,r;
    while(scanf("%d",&n) && n){
        build(1,1,n+1);
        for(int i=1;i<=n;i++){
            scanf("%d %d",&l,&r);
            updata(1,r+1,-1);
            updata(1,l,1);
        }
        for(int i=1;i<=n;i++){
            if(i>1) printf(" ");
            printf("%d",query(1,1,i));
        }
        printf("\n");
    }
    return 0;
}