Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

 

题意

初始n*n的矩阵全为0

Q个操作

1.[X1,Y1]-[X2,Y2]中取反操作

2.查询[X1,Y1]的值

题解

1.区间更新分成4块,([X1,Y1]-[n,n])([X2,X2]-[n,n])([X2+1,Y1]-[n,n])([X1,Y2+1]-[n,n]),每个区间都+1操作,只保证[X1,Y1]-[X2,Y2]+1,其余+2或者+4

2.单点查询[X1,Y1]的值,只需要查询[X1,Y1]的值%2即可

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
int X,n,t;
using namespace std;
const int N=1010;
int tree[N][N];
void init(){
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            tree[i][j]=0;

}
int lowbit(int x){

    return x&(-x);
}
void updata(int x,int y,int C){
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            tree[i][j]+=C;
}
int query(int x,int y){
    int res=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            res+=tree[i][j];
    return res;
}
int main()
{
    scanf("%d",&X);

    while(X--){
        scanf("%d%d",&n,&t);
        init();
        char tmp[10];
        int x,y,x2,y2;
        while(t--){
            scanf("%s",tmp);
            if(tmp[0]=='C'){
                scanf("%d%d%d%d",&x,&y,&x2,&y2);
                updata(x,y,1);
                updata(x2+1,y,1);
                updata(x,y2+1,1);
                updata(x2+1,y2+1,1);

            }else{
                scanf("%d%d",&x,&y);
                cout << query(x,y)%2 << endl;
            }



        }
        if (X) cout  << endl;

    }
    //cout << "Hello world!" << endl;
    return 0;
}