描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011

样例输出
3
0
3

鉴于此题数据范围较小,可以使用朴素算法解决,不必使用kmp。所以,还是一道水题……

#include <stdio.h>
#include <string.h>

int main(int argc, const char * argv[])
{
    int N;
    char A[11], B[1001];
    int lenA, lenB, flag, ans;
    scanf("%d", &N);

    while (N--)
    {
        ans = 0;
        scanf("%s %s", A, B);
        lenA = (int)strlen(A);
        lenB = (int)strlen(B);

        for (int i = 0; i < lenB - lenA + 1; i++)
        {
            flag = 1;
            for (int j = 0; j < lenA; j++)
            {
                if (A[j] != B[i + j])
                {
                    flag = 0;
                    break;
                }
            }
            if (flag)
            {
                ans++;
            }
        }

        printf("%d\n", ans);
    }

    return 0;
}