1013. Battle Over Cities (25)
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.
Input
Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.
Output
For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
题目大意:
给定一个无向图,求拿掉一个节点,剩下的连通分量个数减一。
题目解析:
每次先将拿掉的节点visisted设为已访问,不计入连通分量个数,剩下的用dfs统计连通分量个数。
具体代码:
#include<iostream>
using namespace std;
#define MAXN 1010
int R[MAXN][MAXN];
int vis[MAXN];
int n,m,k;;
void dfs(int v){
vis[v]=1;
for(int i=1;i<=n;i++)
if(vis[i]==0&&R[v][i]==1)
dfs(i);
}
int main()
{
fill(R[0],R[0]+MAXN*MAXN,0);
cin>>n>>m>>k;//n为城市的总数,m为路的总数
int a,b;
while(m--){
cin>>a>>b;
R[a][b]=R[b][a]=1;
}
while(k--){
int count=0,a;
cin>>a;
fill(vis,vis+MAXN,0);
vis[a]=1;
for(int i=1;i<=n;i++)
if(vis[i]==0){
dfs(i);
count++;
}
cout<<count-1<<endl;
}
return 0;
}