1115 Counting Nodes in a BST (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n
where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6

题目大意:

求给出一串数字建立二叉搜索树,然后求最底下两级的元素个数。

题目解析:

可以用指针的方法,也可以用数组(如下),在建立搜索树的时候存储级别,最后遍历数组。

具体代码:

#include<iostream>
#include<algorithm>
using namespace std;
struct node{
	int level;
	int key;
	int left=-1,right=-1;
}A[1100];
int maxlevel=0;
void addnode(int root,int child,int level){
	if(level>maxlevel)
		maxlevel=level;
	if(A[child].key<=A[root].key){
		if(A[root].left==-1){
			A[root].left=child;
			A[child].level=level;
		}
		else
			addnode(A[root].left,child,level+1);
	}else{
		if(A[root].right==-1){
			A[root].right=child;
			A[child].level=level;
		}
		else
			addnode(A[root].right,child,level+1);
	}
}
int main()
{
    int n;
    cin>>n;
    cin>>A[0].key;
    A[0].level=0;
    for(int i=1;i<n;i++){
    	cin>>A[i].key;
    	addnode(0,i,1);
	}
	int n1=maxlevel,n2=maxlevel-1;
	int count1=0,count2=0;
	for(int i=0;i<n;i++){
		if(A[i].level==n1)
			count1++;
	}
	for(int i=0;i<n;i++){
		if(A[i].level==n2)
			count2++;
	}
	printf("%d + %d = %d",count1,count2,count1+count2);
    return 0;
}